Contrast adjustment changes the selected image when filtering by XMP rating

Forums: 

When increasing or decreasing contrast using either Menu,Adjust, hotkeys or clicking on the arrows on the bottom bar...The adjustment is made to the selected image BUT/AND FRV moves to another selected image!  It is moving to one of the earliest images for the current filter.  This behavior does NOT occur when no filter is set. Please advise.
Thanks

Dear Sir:

this should not works this way :)

Please:

1) Go to Preferences - Other and change Debug log messages to All

2) Reproduce the problem

3) Go to Menu - Help - Debug log, save the Debug log and send it to support@fastrawviewer.com

I have uploaded the debug log.  However, I now see that almost any change to the image made on the bottom bar (WB, exposure, contrast) produces a move from the active/selected image to the first image (first or second file in the list).  For example, I am looking at 58/200...I change the WB...displayed image and filmstrip/thumbnail changes to 2/200.
Help!

Phil Adams

Debug log received, thanks.

It is great to hear, that  *any* file display updates (WB, contrast, exposure) results in the same (but wrong) behaviour because all of them works the same way (it was very strange to hear that only contrast change works this way).

Unfortunately, our current debug log records are not enough to detect the problem in depth. We'll prepare special debug version with more extensive logging today or tomorrow and will contact you again for more detailed logs.

 

If someone experience the same problem: the workaround is implemented in FRV 1.4.10 via AlternateFilteringPosRecovery script/hidden setting.

Add new comment