XMP color labels bug

Forums: 

Hi. I have a problem with purple color label in XMP sidecard. FRV won't read this data. Others color labels works but the purple doesn't read. I have custom colors preset created in Lightroom and the same value in FRV. I tried default colors in LR and FRV and the same.

Lightroom CC Classic 7
FRV 1.4.5 actual
Windows 10 x64

Dear Sir:

Please e-mail the XMP file where we don't read the purple label and your FastRawViewer settings files (FastRawViewer Main menu - Help - "Auxillary settings scripts" - Backup Settings script; the files will be in ~/Documents/FRV-backup)

Our e-mail is support@fastrawviewer.com

 

FRV won't read purple color label from all XMP files in my catalog. It looks like a bug in comparing the strings from TextBox control and XMP sidecard.
FRV 1.4.5 release build 1206

Thank you for providing sample files, it makes bug search very easy.

The bug in reading 5th (purple) label is fixed in FastRawViewer 1.4.6-1210

Although it is labeled as 'beta', new feature list is not big now and very local, so it is safe to use this version for everyday work.

Download it from: https://www.fastrawviewer.com/blog/FastRawViewer-1-4-6-beta (scroll to page bottom for download links).

Please note, that 1.4.6 introduces new feature 'quick copy/move to subfolder' (of current folder). It is enabled by default in beta, if you do not need it, you may disable this feature via Preferences - Copy/Move/Reject - uncheck Enable quick copy/move to subfolder

I too have been plagued with this issue. I will also download the beta and install it. I also have this issue with thumbnails going on since the last update: https://photos.app.goo.gl/q8IE6F6kDvBg0hpy2
 
Last night I was selecting photos from over 1,000 (using purple) and when I moved the slider all the way back to the front, it lost about 100 out of 140 I had selected. Just gone. I had to take a break at that point.

And after installing the beta, I'm still getting that weird thumbnail issue where it's fetching them and then the green bar goes back down and the thumbnails keep jumping. This wasn't ocurring until the latest stable release. 

Dear Sir:

Thank you, we will look into that. Please contact us at support@fastrawviewer.com

Done.

Dear Sir:

we've examined FRV internals in depth in regard of thumbnail/metadata cache (read and expiration).

Yes, in some cases, when

 - Thumbnail cache size set not big enough to hold all thumbnails in current folder

 - and Metadata filtering or sorting is used

it is possible, that thumbnail expiration from cache will result into metadata expiration too => sort/filtering changed => other thumbnails displayed => other thumbnails expired loop (sorry for long explanation).



We attempted to fix this problem in new beta build (1.4.6-1227), please download it from updated beta announce page: https://www.fastrawviewer.com/blog/FastRawViewer-1-4-6-beta3

and provide us w/ feedback.

Add new comment